No video output [XU4]

edited December 2016 in Troubleshooting
Hello everyone,

I just received my IndieGO! Console, I added a 2.5" HDD and replaced the DVD drive with a Blu-ray one, and now I am trying to boot the Odroid.

On powering the device, the Blu-ray drive seems to be able to eject and respond. Inside the case I can see the Odroid's LED's shine. (one red light, constantly, and a blue light blinking, in a heartbeat fashion) However, and I tested the HDMI cable, I do not get any video output.

I plugged the Y-Cable in two of the 2.4A ports of the included 6-port powered hub, along with the red USB connection powered on a 2.4A port as well.

Both the Wi-Fi and Bluetooth stick are connected to the internal USB hub. I took out one USB Hub to connect my HDD to USB 3.0, I connected the Y cable of the SATA to USB cable to the Hub with the red USB connection, powered to the 2.4 port mentioned before. I can hear the HDD spinning without issue's.

Are there any more requirements or idea's or things I can try to make a video output pop up?

Thanks in advance!



  • Hi,

    64gb sd is what was meant by me. The 32gb card was copied over and not removed.

    The bd re and the hdd need one cable routed out to the USB charger.

    The other one from the y-cable should be connected to another hub.

    Bt should be connected to the rear USB
    Else is draws too much current from a single USB port of the xu

    Is the XU4 led blue or red?
    Red means bad
    Blue would be ok

    Make sure that the hdmi cable is attached correctly. A half milimeter can do the difference.

    Than make sure to power on the tv first and to choose hdmi on the tv before powering it on.

    The tv must be able to show 720p or more

    I assume the cable isn't plugged in as far as possible to the xu4
  • edited December 2016

    Ah, cool. :)

    And, yes, the BD/DVD drive is connected bij the SATA to USB Y splitting cable, with the Red plug connected to the included 6 port powered hub.

    I actually had forgotten to connect the BT and WiFi stick back into the case, so those aren't currently plugged in. But I will remember that.

    The XU4 has a red led, constantly on. And the blue led, constantly flashing like a heartbeat. So, both of these are turned on? Or what could this indicate?

    I have tested the XU4 separately from any USB devices, only with the SD card and power, I tried to put quite a bit of force onto the HDMI cable, to make sure it was plugged in completely.

    I have a 1080p LG TV.

    The fan does stop spinning after a while, but the led lights continue to do as I described above.

    Thanks for taking the time and help so fast, I know you probably must be overwhelmed by people emailing you right now.

  • I seem to have fixed it by outsourcing a USB Y-Cable going to the TV instead of the the 6-port usb hub power supply.

    This causes the Odroid and my TV to share ground, this seems to be a reoccurring issue since the Odroid C2.
  • Interesting, this is new for me.
    Good that you fixed it.
    I will release tomorrow another update which fixes all Game entries in the menu (some are dead end)
  • Unrelated, but regarding Game enteries in the emulation station menu, under de Roms folder on the SD card you can place roms and it will see them mostly.

    How are we supposed to add an external storage source for more Roms, like a HDD, for usage with emulation station?
    And my N64 and CDi games do not show up on the emulation station, I assume that is because I lack the BIOS files, where do I put those?
  • N64 should work without bios but it has some quirks in the moment due to driver updates.
    CDi may just not be "setup" correctly and yes it would require a bios files.. I need to investigate.
Sign In or Register to comment.